Isuzu SUV Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi All,

I searched the boards here and found many cases similar to mine, but not exactly.

I am getting the flashing gear indicator lights on the dash with a loss of power, feels like the car is jumping in and out of gear. This only happens from a cold start, like in the morning going to work or in the even after work. If I go out to lunch it does not do it so it is when the truck sets between 4-8 hours.

Also, the truck has no pulling power at all. I actually got stuck in a friend's driveway because the truck wouldn't climb out. I had to pull into his garage and get a running start in order to get out of the driveway! I can even feel that it struggles going up a hill. If I am driving on flat road at 45 MPH and there is a steep hill on the road it bogs down and starts to smell as though it is overheating.

I took it to Isuzu and they said the part was not covered under the powertrain warranty and I was outside the bumper-to-bumper. They are saying it is a transmission mode switch and will cost me a little over $300 to replace.

Any ideas on this one? Does the price sound in-line for that type of repair?

Thanks,
 

·
Registered
Joined
·
149 Posts
Tim - sounds like the transmission range sensor. If you look at the sticky at the top of this part of the discussion boards, you will see a topic from me that addresses this issue. You can remove and clean the range sensor for next to nothing, or buy one and replace it outright.

Tom
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top