Isuzu SUV Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi-
It's a 3.5L with 47K.
The engine light was flashing at me today after a car wash....it lit up once before after a tank of bad gas, I think. I threw a bottle of injector cleaner and pumped some 93 octane into her and it went off.
I am wondering why it was flashing at me today....also the idle seems low lately, a little rough, and especially after I put it into park it drops way down then back up, is this normal?

Thanks, this is my first post, and yes I surf on Lake Michigan.
Matt
I love the truck!
 

·
Registered
Joined
·
1,238 Posts
The car wash thing could be a fluke. If you don't see the flashing light on start up again I wouldn't worry about it.

As for idle, clean out your Throttle body with some carb cleaner (safe for 02 sensors), and flush your power stearing fluid (I just pull the lower hose on my fluid res and drain and refill, jack up both front wheel, start up, and go from stop to stop with the steering wheel). There is some sensor that gets plugged up in the power stearing that raise the rpm a bit at the steering stop (some folks have just unpluged the sensor with no problems).,

Check your gas cap to make sure it was tight!
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
The idle will drop real low when put into park...why does that happen?
At 47K, no other service has been done except oil changes, what do you guys recommend? Tune Up?
Maybe the misfire would be solve with new plugs? And or plug wires?

I do plan to install a Calmini 2" lift this coming spring, so I want this thing to last. What is the largest tire size I can fit with the lift and stock 16x7 rims?

Thanks for all the help...
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
Well, the light came back on last night and is still on.
My plan is to take it Autozone and have the free computer reading done.
Then head to a local mechanic tell him what I have learned from this and other areas as to what the issue may be.
The car is not under warranty anymore, I think it was a 3/36,000....I bought it used with 28K on it. Just hit 48K last night.

Any other thoughts? It almost feels like it is missing lately, not all the time just when running at idle. And then the drop when it's put into park...

Any other help?

Thanks in advance
 

·
Registered
Joined
·
192 Posts
LakeMISurfer said:
Well, the light came back on last night and is still on.
My plan is to take it Autozone and have the free computer reading done.
Then head to a local mechanic tell him what I have learned from this and other areas as to what the issue may be.
The car is not under warranty anymore, I think it was a 3/36,000....I bought it used with 28K on it. Just hit 48K last night.

Any other thoughts? It almost feels like it is missing lately, not all the time just when running at idle. And then the drop when it's put into park...

Any other help?

Thanks in advance
Basic warr. for you will be 3 year 50,000 miles. As long as your under both, your under warranty. Better hurry up.

http://www.isuzu.com/owners_warranty_2000to2002.jsp

Good Luck,
Con
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
I called Isuzu and sure enough the warranty is still on....till Dec. 20th~!

Holy****....the car still has 2 open recalls on it, one being the fuel line..I will have these parts done and have the engine light issue checked.

Will post results.

Thanks ConMan , you DaMan.
 

·
Registered
Joined
·
192 Posts
LakeMISurfer said:
I called Isuzu and sure enough the warranty is still on....till Dec. 20th~!

Holy****....the car still has 2 open recalls on it, one being the fuel line..I will have these parts done and have the engine light issue checked.

Will post results.

Thanks ConMan , you DaMan.
Glad you made it! :D Most people did not realize the standard bumper to bumper is 3 years 50k miles as most think only 36k like the rest. What was the second recall? I remember the fuel line protector one but I'm not sure what the second one your talking about. The only other thing that comes to mind is a TSB that reprograms the Tranny Computer. I don't remember if it's for the Trooper or not so you might want to check.

Good Luck,
Con
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #12 ·
Well the enigne light is off, but after 8 sec. after coming to a complete stop the engine rpms drop and it feels like the engine shudders a little.
It'll be at the dealer on Friday, any other thoughts on this so I can at least offer some advice if they turn out to be idiots?
 

·
Registered
Joined
·
591 Posts
surfer- this definately sounds like a bad intake manifold gasket. VERY common on 1998+ 3.2/3.5's. Do a search on this site, or the 4x4wire isuzu site & you'll see tons of posts in regards to bad IMG's. It causes the same conditions you describe & will be a freebie powertrain warranty covered repair for 5yrs/60Kmi if you are the second owner, or 10yrs/120Kmi if you are the original owner.

G/luck
Joel
 

·
Registered
Joined
·
192 Posts
LakeMISurfer said:
Well the enigne light is off, but after 8 sec. after coming to a complete stop the engine rpms drop and it feels like the engine shudders a little.
It'll be at the dealer on Friday, any other thoughts on this so I can at least offer some advice if they turn out to be idiots?
Since the light is out, don't unplug your battery so it keeps the codes in memory. let us know what's up.

Con
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #15 ·
Talked to the dealer this morning the two recall repairs were:
1.) Fuel Hose
2.) Fuel hose shield
Repairs for bad idle and rpm drop when put into park:
1.) Intake Manifold Gasket CODE was 1151 & 1241
2.) Leaky Fuel Pressure Regulator CODE was P0300

She runs so much better, even at speed it seems smoother, idle still seems a little low but at least it's steady and not stalling. Whats the normal idle speed??

Now I can start my saving for the Calmini kit!~
 

·
Registered
Joined
·
192 Posts
LakeMISurfer said:
Talked to the dealer this morning the two recall repairs were:
1.) Fuel Hose
2.) Fuel Tank shield
Repairs for bad idle and rpm drop when put into park:
1.) Intake Manifold Gasket
2.) Leaky Fuel Pressure Regulator
Glad your all fixed up(under warranty). :) I'm still waiting for my new fuel pressure regulator....... :(
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top