Isuzu SUV Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2000 Rodeo that I just got back on the road after months of it not starting. I started to notice that the check engine and transmission lights were coming on and my car would jerk, but not turn off. Then the car was having a hard time starting. For my husband it took many tries to finally start, giving it gas and when it finally caught on it would make a backfiring sound. Or I had a trick where I would turn the key and after a few seconds of beeping I would turn the key all the way and the car would start. We had the starter replaced, tune ups, even took it to the Isuzu dealer and they ran a diagnostic and couldn't find the problem. Finally my mechanic said it was the sensor behind the accelerator, so I changed out my whole pedal. Now the car starts fine, but just a couple of days ago the check engine and transmissions lights were coming on sporadically, and today it started jumping (one time) and turning off when stopped at red lights. Of course when it stalls all the dashboard lights come on. Could this be an electronic problem??
 

·
Registered
Joined
·
11,917 Posts
When the CEL is illuminated one or more diagnostic trouble codes (DTCs) are stored that can aid in troubleshooting. You can buy a tool to read these DTCs or go to Autozone and have them read the codes for you. Once you have the codes post them here so the members can determine what needs investigating. A 2000 Rodeo has a complicated electronic throttle control system that could be the problem, the accelerator sensor is part of this system. Other things to check include fuel pressure and alternator output voltage.
 
1 - 2 of 2 Posts
Top