Isuzu SUV Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Car when accelerated the CEL light flashes, and also the speed won't pick up, but the RPM goes up. Once I get past a certain speed it's fine. Just when I accelerate. For example when I'm accelerating to 60MPH, the light will flash all the way to 60MPH. Also my car has some fuel issues it seems. Before I use to get gas milage of about 250 miles per tank, now at 150 miles the fuel light turns on, but when I go get gas it still has lots of gas in it? What could this be? Could it be a fuel level sensor of some sort? Please help. Thanks.
 

·
Registered
Joined
·
327 Posts
ae102gts said:
Car when accelerated the CEL light flashes, and also the speed won't pick up, but the RPM goes up. Once I get past a certain speed it's fine. Just when I accelerate. For example when I'm accelerating to 60MPH, the light will flash all the way to 60MPH. Also my car has some fuel issues it seems. Before I use to get gas milage of about 250 miles per tank, now at 150 miles the fuel light turns on, but when I go get gas it still has lots of gas in it? What could this be? Could it be a fuel level sensor of some sort? Please help. Thanks.
If I'm not mistaken, a flashing CEL indicates misfiring. Take it to your local AutoZone and see if there are any codes.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
would the car misfire if proper fuel is not gotten? I did take it to Autozone and they said it was a fuel level sensor of some sort and only the dealer can sell the part/fix it. Would yyou guys know if this would be a repair done under the factory powrtrain warantee?
 

·
Registered
Joined
·
591 Posts
You've got completely seperate issues going on here. Like canucklehead says, the "flashing" CEL on an OBDII equiped vehicle (like yours) means you have something going on that can lead to engine or emissions system damage. Likely a misfire, which left unchecked will destroy your catalytic converter(s). A bad sending unit (fuel level float/sensor) in the gas tank causes your gas gauge not read properly- too common on 1998-2000 3.2L's. This will also give it's own code + light up the CEL & low gas light, but not cause a flashing CEL. You may want to repair or replace the gas tank sending unit first, then trouble shoot the flashing CEL (that occurs less frequently) later.
G/luck
Joel
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
appreicate everyone's help. Ok so this car is still waranteed by the 10yr 120K powertrain warrantee, does anyone know if this is something covered in the powertrain warrantee? This sounds like it should be a recall on these vehicles. If it is covered by warrantee, do you think it be a good idea to let the dealer handle w/ warantee, I just don't like giving them $100 for free everytime I go in. It seems they never want to take fault.

Also regarding the misfiring, is it time for new spark plugs and wires? This issue doesn't occur all the time, just once in a while the CEL will flash. Also I'm not sure but Autozone could only find one code and that was for the fuel level sensor, no other codes were found. Could other tranny issues be present from it not shifting properly? Again I appreciate all your help. Thanks.
 

·
Registered
Joined
·
204 Posts
Mine's doing the same thing...

Except I know exactly what the problem is...

Cracked junky plastic lower intake manifold gasket.

I replaced these last winter, and now it's doing it again.

You can actually hear the sucking of the vacuum leak.

Here's hoping I don't melt a piston due to a lean condition. Replacing "gaskets" again tomorrow night. Yoi.

$43-something at Auto Zone.

If you've never done this before, you might want to pick up some Injector O-rings and some petroleum jelly [vaseline], too.

Takes about 4-6 hours if you can get to all the bolts without getting frustrated...
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top