Isuzu SUV Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter · #1 ·
1)Check engine light comes on from time to time. At first, I thought it was the EGR, it sent out a code for that, so that's been replaced. A month or two later, it starts back. New gas cap, went away for a while. It's back. I'm thinking maybe it's a misfire? Only seems to come on when the engine is wound out, and it goes away after a few starts (10-20), which sounds like it is a one time trip that doesn't continue, so it turns off. Any ideas? Could it be O2 sensors, or they're just setting it off for too much fuel getting through? I don't know. It runs fine though.

2)Is there any new development in the mysterious disappearing oil deal with the 3.2L? I know Isuzu says 1 qt every 1000 miles is okay with them, but it's my biggest reason I sometimes want to get rid of the Amigo. No smoke, no leaks.

I don't think the 2 are related, BTW.
 

·
Registered
Joined
·
591 Posts
1) Bill, what trouble code are you getting now? any operational issues?
2) Per an isuzu tech (Keith) on the suv.com site, the oil consumption on earlier DOHC 3.2/3.5 (1998-1999, maybe early 2000) is due to the lack of drainback holes on the piston oil rings. Old design only had 4, new design has 10+. Oil cant drain out properly on the "old" design, gets trapped & burns off in the cylinder. G/luck
Joel
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top